About the CCNP category

Ask Questions related to CCNP

BGP : related question,
Topology

image

following is the configuration provided on each router .
we are advertising 4.4.4.4 from R4 and checking its effect on all the four router

enable
configure terminal
hostname R1
interface fa 0/1
ip address 192.168.12.1 255.255.255.0
no shutdown

	interface fa 0/0
		ip address 192.168.13.1 255.255.255.0
		no shutdown
	
	router BGP 1
		neighbor 192.168.12.2 remote-as 2
		neighbor 192.168.13.3 remote-as 3

!-----------------------------------------

enable
configure terminal
hostname R2
interface fa 0/1
ip address 192.168.12.2 255.255.255.0
no shutdown

	interface fa 0/0
		ip address 192.168.24.2 255.255.255.0
		no shutdown
			
	router BGP 2
		neighbor 192.168.12.1 remote-as 1
		neighbor 192.168.24.4 remote-as 4

!-----------------------------------------
enable
configure terminal
hostname R3
interface fa 0/0
ip address 192.168.13.3 255.255.255.0
no shutdown

	interface fa 0/1
		ip address 192.168.34.3 255.255.255.0
		no shutdown
		
	router BGP 3
		neighbor 192.168.13.1 remote-as 1
		neighbor 192.168.34.4 remote-as 4

!-----------------------------------------
enable
configure terminal
hostname R4

	interface loopback 0
		ip address 4.4.4.4 255.255.255.255
		
	interface fa 0/0
		ip address 192.168.24.4 255.255.255.0
		no shutdown 
			
	interface fa 0/1
		no ip address 192.138.34.4 255.255.255.0
		ip address 192.168.34.4 255.255.255.0
		no shutdown
			
	router BGP 4
		neighbor 192.168.24.2 remote-as 2
		neighbor 192.168.34.3 remote-as 3
		network 4.4.4.4 mask 255.255.255.255

!=================================================

following is the observation

on R4

R4#show ip bgp
BGP table version is 2, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 4.4.4.4/32 0.0.0.0 0 32768 i

///////////////////////////////////////////////////////////////////////////////////////////

on R3

R3#show ip bgp
BGP table version is 2, local router ID is 192.168.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

  • 4.4.4.4/32 192.168.13.1 0 1 2 4 i
    *> 192.168.34.4 0 0 4 i

/////////////////////////////////////////////////////////////////////////////////////////////

on R2

R2#show ip bgp
BGP table version is 2, local router ID is 192.168.24.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 4.4.4.4/32 192.168.24.4 0 0 4 i

////////////////////////////////////////////////////////////////////////////////////////////////////////

on R1

R1#show ip bgp
BGP table version is 2, local router ID is 192.168.13.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path

  • 4.4.4.4/32 192.168.13.3 0 3 4 i
    *> 192.168.12.2 0 2 4 i

//////////////////////////////////////////////////////////////////////////////////////////////////////

I have understood the concept , now only thing which I could not follow is that why there are two entry in R3 and one entry in R2 , further if we do clear ip bgp * then it is visa versa .
kindly help me in understanding this . Thank you !

Home Official Website Video Portal