Ospf-lab (open shotest path first)

DELHI-ROUTER:

enable
configure terminal
hostname Delhi-router
interface fastethernet 0/0
ip address 192.168.11.1 255.255.255.0
no shutdown

interface fastethernet 1/0
ip address 192.168.1.1 255.255.255.0
no shutdown

interface fastethernet 0/1
ip address 192.168.10.2 255.255.255.0
no shutdown

MUMBAI-ROUTER

enable
configure terminal
hostname Mumbai-router
interface fastethernet 0/0
ip address 192.168.11.2 255.255.255.0
no shutdown

interface fastethernet 1/0
ip address 192.168.3.1 255.255.255.0
no shutdown

interface fastethernet 0/1
ip address 192.168.12.2 255.255.255.0
no shutdown

KOLKATA-ROUTER

enable
configure terminal
hostname Kolkata-router
interface fastethernet 0/0
ip address 192.168.10.1 255.255.255.0
no shutdown

interface fastethernet 0/1
ip address 192.168.2.1 255.255.255.0
no shutdown

CHENNAI-ROUTER

enable
configure terminal
hostname Chennai-router
interface fastethernet 0/1
ip address 192.168.12.1 255.255.255.0
no shutdown

interface fastethernet 0/0
ip address 192.168.4.1 255.255.255.0
no shutdown

OSPF CONFIGURATION ON DELHI-ROUTER:-

configure terminal
router ospf 10
network 192.168.1.0 0.0.0.255 area 0
network 192.168.11.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.255 area 5

==========================================
OSPF ON MUMBAI-ROUTER:-

configure terminal
router ospf 10
network 192.168.11.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
network 192.168.12.0 0.0.0.255 area 10

OSPF ON KOLKATA ROUTER:-

configure terminal
router ospf 10
network 192.168.2.0 0.0.0.255 area 5
network 192.168.10.0 0.0.0.255 area 5

OSPF ON CHENNAI ROUTER:-

configure terminal
router ospf 10
network 192.168.12.0 0.0.0.255 area 10
network 192.168.4.0 0.0.0.255 area 10

DHCP POOL ON DELHI-ROUTER & MUMBAI-ROUTER:-

configure terminal
ip dhcp pool Delhi-R
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1

ip dhcp pool Kolkata-R
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1

ip dhcp pool Mumbai-R
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1

ip dhcp pool Chennai-R
network 192.168.4.0 255.255.255.0
default-router 192.168.4.1

IP HELPER ON KOLKATA-R:-

configure terminal
interface fastethernet 0/1
ip helper-address 192.168.10.2
ip helper-address 192.168.11.2

IP HELPER ON CHENNAI-R:-

configure terminal
interface fastethernet 0/0
ip helper-address 192.168.10.2
ip helper-address 192.168.11.2

DONE…DONE…DONE