Svi lab-2 configuration

ASW1 CONFIGURATION

enable
configure terminal
hostname ASW1
vlan 10
name GRUOUND-FLOOR
interface range fastethernet 0/1 -2
switchport mode trunk
interface fastethernet 0/3 - 4
switchport access vlan 10

ASW2

enable
configure terminal
hostname ASW2
vlan 20
name FIRST-FLOOR
interface range fastethernet 0/1 - 2
switchport mode trunk
interface range fastethernet 0/3 - 4
switchport access vlan 20

ASW3

enable
configure terminal
hostname ASW3
vlan 10
name GROUND-FLOOR
interface range fastethernet 0/1 - 2
switchport mode trunk
interface range fastethernet 0/3 -4
switchport access vlan 10

ASW4

enable
configure terminal
hostname ASW4
vlan 20
name FIRST-FLOOR
interface range fastethernet 0/1 -2
switchport mode trunk
interface range fastethernet 0/3 - 4
switchport access vlan 20

DSW1 CONFIGURATION…

enable
configure terminal
hostname DSW1
vlan 10
name ground-floor
vlan 20
name first-floor
interface range fastethernet 0/1 - 4
switchport trunk encapsulation dot1q
switchport mode trunk

CONFIGURE SWITCH VIRTUAL INTERFACE…

interface vlan10
ip address 192.168.10.1 255.255.255.0
no shutdown

interface vlan 20
ip address 192.168.20.1 255.255.255.0
no shutdown
ip routing

TO VERIFY TYPE…

show ip interface brief

====================================================
DSW2

enable
configure terminal
vlan 10
name ground-floor
vlan 20
name first-floor
interface range fastethernet 0/1 - 4
switchport trunk encapsulation dot1q
switchport mode trunk

CONFIGURE SWITCH VIRTUAL INTERFACE…

interface vlan 10
ip address 192.168.10.2 255.255.255.0
no shutdown

interface vlan 20
ip address 192.168.20.2 255.255.255.0
no shutdown
ip routing

TO VERIFY…

show ip interface brief

======================================================
DHCP POOL CONFIGURE ON DSW1 SWITCH…

ip dhcp pool vlan-10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1

ip dhcp pool vlan-20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1

DHCP POOL CONFIGURE ON DSW2 SWITCH…

ip dhcp pool vlan-10
network 192.168.10.0 255.255.255.0
default-router 192.168.10.2

ip dhcp pool vlan-20
network 192.168.20.0 255.255.255.0
default-router 192.168.20.2