Vlan config prob 2

i am mention the network ip for marketting is 100.10.10.0 & default route is 100.10.10.1 but the computers of this section is getting ip 100.10.0.1 series
please is explsin why is happening
enable
configure terminal
hostname headoffice

interface fa0/0
ip address 100.10.10.1 255.255.0.0
description marketting
no shutdown

interface fa1/1
ip address 20.20.20.1 255.255.255.0
description HR

interface fa1/0
ip address 20.11.80.1 255.255.0.0
description BSNL
no shutdown

interface fa0/1
ip address 10.166.86.1 255.255.255.0
description JIO
no shutdown

ip route 0.0.0.0 0.0.0.0 fa0/1 1
ip route 0.0.0.0 0.0.0.0 fa1/0 2

ip dhcp pool maarketting
default router 100.10.10.1
network 100.10.10.0 255.255.0.0

ip dhcp pool HR
default router 20.20.20.1
netwirk 20.20.20.0 255.255.0.0

enable
configur terminal
hostname switch

vlan 100
name marketting

vlan 200
name HR

int range fa0/1-2,fa0/4
switchport access vlan 100
int fa0/6
switchport access vlan 100
int fa0/3
switchport access vlan 200
int fa0/5
switchport access vlan 200
int fa0/7
switchport access vlan 200

enable
configur terminal
hostname switch1

vlan 100
name marketting

vlan 200
name HR

int range fa0/3-4,fa0/6
switchport access vlan 100

int range fa0/1-2,fa0/5
switchport access vlan 200

@Atul_Sharma sir please reply on it.

f1/1 interface down
u need to give
no shutdown command

sir system dusare vlan ki ip show kar raha hai yaha please tell me what is the problm in config

system means pc?
keep it aside, ur router is not properly configured, i pointed out one issue i.e f1/1 down